Monday, September 26, 2005

DUH!

Saturday night, I went over to my niece's to pick her up to go scrapbooking. As we got back into the car to leave, it wouldn't start. The lights, air, etc worked, but the motor would'nt budge. We ended up taking her car, and left mine there for my brother in law to take a look at.

He called this morning with the verdict...he said it started fine, after he put it into PARK! DOH!

I'm an idiot. What can I say?!?

10 comments:

SalGal said...

At least you didn't lock yourself out of your car... WHILE IT WAS RUNNING.

Bree said...

That's classic!

Gem said...

Oh, my goodness, are you sure you don't have blonde roots?

monica said...

Wow.. you really do have bad luck! LOL!
Cheers!

weirsdo said...

That has happened to my husband and me too. But even though I was the one who put it in park, I was still an idiot for leaving it in something else when I turned it off before.
I did make my husband call the service department back and explain why we didn't need their towing services after all.

Dave said...

Gotta love ya baby! :)

Hubby

Chicka said...

That actually happened to me AT A GARAGE!

I went out to start up my truck (picking it up) and it wouldn't. I went back in and the guy came out and put it in park. (It looked like it was in park, but it wasn't engaged fully. Weird.)

Hey, at least it wasn't anything else that costs money!

S said...

Oh gosh I hate it when I do something like that! 8-|

peebugg said...

I spent about 10 minutes trying to get my keys out of the ignition one day. Finally looked down and then I put it in park......

You're not alone...

Lou said...

haha! I did that once. It was Veeeery embarassing!